Missing ... in i10n_de.xml

Antworten
Benutzeravatar
fantomasius
Beiträge: 113
Registriert: Mo 8. Dez 2014, 09:50
Danksagung erhalten: 2 Mal

Missing ... in i10n_de.xml

Beitrag von fantomasius » Mo 5. Jul 2021, 16:31

:hi: Hallo
Nach längerer Zeit mal eine Frage.
Ich habe ONION und CARROT in meine map eingebaut. Soweit alles gut, nur die Meldung stört mich.
Einfache Frucht Registrierung ohne GC.

Missing `fillType_carrot ` in l10n_de.xml
Missing `fillType_onion ` in l10n_de.xml

Ich habe die l10n_de.xml im maps Ordner und dort folgendes stehen

<l10n>
<texts>
<!-- Filltypes -->
<text name="fillType_charcoal" text="Holzkohle" />
<text name="fillType_flour405" text="Mehl405" />
<text name="fillType_flour550" text="Mehl550" />
<text name="fillType_onion" text="Zwiebeln" />
<text name="fillType_carrot" text="Karotten" />
</texts>
</l10n>

Bei den anderen drei fillTypen habe ich keine Probleme

In der ModDesk steht noch folgen des.

<text name="carrot">
<en>Carrots</en>
<de>Karotten</de>
</text>
<text name="fillType_carrot">
<en>Carrot</en>
<de>Karotten</de>
</text>
<text name="function_haulmTopperCarrot">
<en>Topper carrots</en>
<de>Entkrauter Karotten</de>
</text>
<text name="function_harvestingCarrotWithoutPreparer">
<en>Harvester carrots</en>
<de>Vollernter Karotten</de>
</text>
<text name="onion">
<en>Onions</en>
<de>Zwiebeln</de>
</text>
<text name="fillType_onion">
<en>Onion</en>
<de>Zwiebeln</de>
<pl>Cebula</pl>
</text>
<text name="function_haulmTopperOnion">
<en>Topper onion</en>
<de>Entkrauter Zwiebeln</de>
</text>
<text name="function_harvestingOnionWithoutPreparer">
<en>Harvester for onion</en>
<de>Vollernter Zwiebeln</de>
</text>

Kann mir jemand sagen was ich falsch mache oder warum ich die Missing Meldung bekomme.
In der log konnte ich kein Fehler oder Error erkennen.
Aber wenn sie benötigt wird liefer ich sie nach.

Vorab schon mal ein Danke
MFG Thomas

Benutzeravatar
fantomasius
Beiträge: 113
Registriert: Mo 8. Dez 2014, 09:50
Danksagung erhalten: 2 Mal

Re: Missing ... in i10n_de.xml

Beitrag von fantomasius » Mo 5. Jul 2021, 18:41

:hi: moin moin

Problem gelöst.
Ich habe mir ein paar Maps geladen und in der Suedhemmern bin ich fündig geworden.

Bei den " maps_fillTypes " habe ich jetzt diese Einträge
<fillType name="ONION" title="Zwiebel_onion" showOnPriceTable="true" pricePerLiter="0.9" >
<fillType name="CARROT" title="Karotte_carrot" showOnPriceTable="true" pricePerLiter="0.9" >

Zwiebeln_onion und Karotte_carrot wird jetzt angezeigt.

Kein Missing mehr

MFG Thomas

Benutzeravatar
FalPos
Beiträge: 2374
Registriert: Mo 13. Jul 2015, 19:01
Wohnort: Dresden
Hat sich bedankt: 125 Mal
Danksagung erhalten: 213 Mal
Kontaktdaten:

Re: Missing ... in i10n_de.xml

Beitrag von FalPos » Mo 5. Jul 2021, 20:31

Wenn Du die Karte nur für Dich angepasst hast, reicht es anstelle von Zwiebeln_onion einfach bei "title" nur Zwiebeln eintragen. Gleiches natürlich auch bei den anderen FillTypes. Hast Du aber Produktionen eingebaut, so musst Du eh noch eine l10n_de.xml in der Karte haben. Dann kannst Du die FillTypes auch darin übersetzen lassen. Dazu sollte allerdings der Eintrag in der maps_fillTypes.xml anders aussehen:

Code: Alles auswählen

<fillType name="ONION" title="$l10n_fillType_onion"


Dann folgenden Eintrag in die l10n_de.xml machen:

Code: Alles auswählen

<text name="fillType_onion" text="Zwiebeln" />
Ansonsten wie bereits erwähnt, ist die Karte nur für Dich brauchst Du diesen Weg nicht gehen und trägst bei "title" einfach nur den richtigen Namen ein. Das wäre um beim Beispiel der Zwiebeln zu sein, einfach nur "Zwiebel" und lässt den zusätzlichen englischen Namen weg. Sähe auch irgendwie blöd aus. ;)

Wichtig wäre der Hinweis in der modDesc.xml, das die Übersetzung über diese l10n_de.xml laufen sollen:

Code: Alles auswählen

<l10n filenamePrefix="languages/l10n" />
Support für die Saxonia und Birkenhof ausschließlich hier im Forum, oder auf unten angegebener Website.
Die Website zur Saxonia Support-Seite für die Saxonia, Birkenhof und Multimap 2018 Live-Support Discord: https://discord.gg/Eq7fdVq

Benutzeravatar
fantomasius
Beiträge: 113
Registriert: Mo 8. Dez 2014, 09:50
Danksagung erhalten: 2 Mal

Re: Missing ... in i10n_de.xml

Beitrag von fantomasius » Di 6. Jul 2021, 16:11

:hi: Moin
Vielen Dank, FalPos
Ist nur meine Map.
Danke
MFG Thomas

Antworten

Zurück zu „Allgemein“